DjangoBooks.com

Welcome to our Community!

It looks like you're new here. If you want to get involved, click one of these buttons!

Related Discussions

Who's Online (0)

Today's Birthday

stubby

Ischell Feedback Issues

Hey everyone,

I have the Ischell inside box + CPJ and have been have been experiencing terrible feedback when playing through an AER compact 60. The low cut at 360Hz helps but the feedback is still too bad to play this thing at gigs. Changing the placement doesn't fix the problem either. Has anyone else experienced feedback with an Ischell?

Thanks,
Will

Comments

  • Lango-DjangoLango-Django Niagara-On-The-Lake, ONModerator
    Posts: 1,338
    Bummer. I’ve had my Ischell for about five years and never had this problem.

    Maybe you should send it back for a replacement unit?
    dm7b5wdickerson
    I live in a little tourist town called Niagara-On-The-Lake, Ontario, Canada, which is about twenty miles north of Niagara Falls.

    If you are ever planning on visiting the beautiful Niagara area, feel free to PM me and perhaps we can get together and do some jamming.
  • tbleentbleen Astoria QueensNew Gaffiero
    Posts: 22
    First time I stuck on my Ischell it worked like a charm. Then I had removed it and placed it back on and had this feedback issue -- it was unbearable. But with patience with the placement and working with the putty, I can crank it up without feedback on my AER (Gain and master volume at about half up, which is loud enough for most bar gigs)

    You really have to create a solid "donut" shape with the putty and make sure there are no air holes or openings and the mic is really nestled in there tight. Give the mic a good push into the putty. Also, I found the placement of the mic did affect the feedback. Mine is now just inside of the bridge under the A/D strings and works well.
    dm7b5wdickerson
  • wdickersonwdickerson Austin, TXNew Holo #73
    Posts: 34
    Thanks tbleen, I adjusted the placement and seal yesterday and it sounded great at my gig with no feedback! Appreciate the help.
  • wdickersonwdickerson Austin, TXNew Holo #73
    Posts: 34
    In case someone else is having trouble with their Ischell, it turns out I was using the wrong cables! I was using balanced TRS cables instead of unbalanced TS, which the instructions call for. I switched to TS and it's sounding great!
  • Lango-DjangoLango-Django Niagara-On-The-Lake, ONModerator
    Posts: 1,338
    That’s good. I hope you are as happy with yours as I have been with my Ischell.

    Hey, I hate to sound like a broken record but.... as I’ve often mentioned around here, I finally mounted my Ishell pickup inside the guitar body under the bridge between the A and D strings.

    Sounds stupid, but it worked perfectly and now I don’t have deal with that gummed-look and the little thin wire... plus you get this nice natural reverb that fattens the sound a bit... check it out!

    Merry solstice celebration of your choice,

    Will
    Buco
    I live in a little tourist town called Niagara-On-The-Lake, Ontario, Canada, which is about twenty miles north of Niagara Falls.

    If you are ever planning on visiting the beautiful Niagara area, feel free to PM me and perhaps we can get together and do some jamming.
Sign In or Register to comment.
Home  |  Forum  |  Blog  |  Contact  |  206-528-9873
Follow Us
The Premier Gypsy Jazz Marketplace
DjangoBooks.com
Search
Banner Adverts
Sell Your Guitar
Follow Us
© 2019 DjangoBooks.com, all rights reserved worldwide.
Software: Kryptronic eCommerce, Copyright 1999-2019 Kryptronic, Inc. Exec Time: 0.043439 Seconds Memory Usage: 3.446114 Megabytes
Kryptronic